软件说明

南京沁恒微电子股份有限公司

 http://wch.cn

软件说明

本驱动只支持WCH品牌PCIe接口转串/并口芯片CH38X，请认准芯片上WCH字样！

PUMPSETUP.exe 用于安装PCIe 卡驱动，还可以修改串并口号、查看设备管理器和设备列表。

驱动支持：

· Windows NT40/ 98/ ME/ 2000/ XP/VISTA/7/8/8.1/10/11/ SERVER 2003/2008/2012/2016/2019 系统。
<注：Windows 驱动经过微软数字签名认证，直接支持WIN7/WIN10 等64位系统>

· DOS 驱动及LINUX 驱动，需进入相应的目录，运行指定的安装及卸载程序。

驱动安装方法：

  1. 将板卡插入电脑PCIe插槽内并开机；
  2. 选择卡的类型；
  3. 点击<安装驱动>按钮进行驱动安装或点击<卸载驱动>按钮进行驱动卸载。
  • 如果提示<无设备驱动可装>，表示没有找到卡，请检查PCIe卡是否已插入PCIe 插槽内或没插好
  • 如果确实已插入板卡，检查PCIe卡是否已插紧，以及PCIe金手指或插槽内有异物，导致卡接触不好，也可以换一个插槽试试。
  • 如果上述检查后仍出此情况，点击<遇到问题请点击>，运行<查看设备列表>程序，搜索"有问题的PCIe 设备"，查看是否存在一个未装驱动的PCIe卡。
  • 驱动装好后，如需调整串并口号，可以点击<遇到问题请点击>按钮，运行<修改串并口号>程序进行调整，支持多串口号同时调整。

目录
Copyright (c) 2021 wch.cn All Rights Reserved


目录

目录

常见安装/使用问题解答

1 -- 驱动安装

2 -- 驱动卸载

3 -- 查看设备ID

4 -- 修改串/并口号

联系我们

Copyright (c) 2021 wch.cn All Rights Reserved


常见安装/使用问题

常见安装/使用问题

在板卡出现问题时请对照以下常见安装/使用问题逐条确认下，问题还未解决的话，
可以把出现的现象及使用环境等详细的信息发送到技术支持信箱 tech@wch.cn 或者
 tech@winchiphead.com 中，我们将尽快答复。

Q1：板卡插到计算机上，没发现提示发现新硬件；或发现新硬件了，
但安装过程中提示“无设备驱动可装”？
A1：1、首先确认板卡上的PCIe 芯片是否为CH38x 系列芯片；
2、如是, 请做下列尝试来确认板卡是否能正常工作：
确认PCIe 卡的金手指表面清洁，如不清洁可将橡皮擦一下；
将板卡拔掉重插／换一个PCIe 插槽／换一台机器重试。

Q2：在网站上为什么找不到CH382/CH384...对应的驱动？
A2：CH38x系列芯片驱动全部放在CH38xDrv.zip驱动包内（x= 2/4...），
下载链接：http://www.wch.cn/downloads/CH38XDRV_EXE.html
内有驱动安装程序PUMPSETUP.EXE，打开软件后先选择PCIe卡的类型
（默认为自动识别安装），然后点击“安装驱动”按钮进行驱动安装，
点击“卸载驱动”按钮进行驱动卸载。驱动包内已对板卡驱动进行了分类，
驱动支持DOS/ Windows NT4.0/98/2000/ME/ XP/ VISTA/ 7/8/8.1/10/11/
Server 2003/2008/2012/2016/2019 32-bit/64-bit以及DOS和Linux 系统，
具体驱动安装方法请见 驱动安装 等。

Q3：怎么判断板卡驱动已装好?
A3：驱动安装成功后，查看设备管理器，会在“多功能卡”中看到CH38x 设备，
以及在“端口(COM和LPT)”中看到PCI Express-SERIAL 或PCI Express-PARALLEL 设备。

Q4：驱动提示安装成功，设备管理器能看到串/并口，但上面有黄色感叹号？
A4：查看“设备管理器”à“端口(COM和LPT)”àPCI Express-SERIAL 或
PCI Express-PARALLEL 设备属性页面内的“设备状态”提示，
正常工作时应显示为：“这个设备运转正常”等；
如出现“设备无法启动”显示，
请将板卡拔掉重插／换一个PCIe 插槽／换一台机器重试；
如出现“无法加载设备驱动”等类似提示，尝试以下方法：
1、请将驱动卸载后，重启再重新安装一下；
2、确认串/并口是否已被使用，如被占用，可以使用“修改串并口号”的工具
来修改COM口/LPT口号（参考 修改串/并口号 ），或在设备管理器内修改
有必要的话，修改成功后重启一下机器。

Q5：在windows2000 系统下用PUMPSETUP.EXE 安装提示“无设备驱动可装”？
A5：可以尝试刷新“设备管理器”找到新硬件设备后再安装；还可以直接再次点击
“安装驱动”按钮进行驱动安装，这个现象是2000系统未及时刷新出硬件造成的。

Q6：怎么区分要安装的设备接口是串口还是并口？
A6：串口的接口一般为9针，并口一般为25/36针，如下图。

Q7：Linux中如何安装ch38x驱动？
A7：请参考相对应文件夹下的README文档。

Q8：驱动在部分64位Windows7下无法安装，提示数字签名无效？
A8：这种情况一般由于该Windows7系统未更新或缺乏安全补丁造成的。请下载
《 InstallNoteOn64BitWIN7_ZH.PDF》（下载链接：中文版本：
http://wch.cn/downloads/InstallNoteOn64BitWIN7_ZH_PDF.html，
英文版本：http://wch.cn/downloads/InstallNoteOn64BitWIN7_EN_PDF.html） 文档，
根据说明更新系统。

目录

Copyright (c) 2021 wch.cn All Rights Reserved


1、驱动安装

1、驱动安装

关机à插入CH38x卡à开机进系统à运行PUMPSETUP.exe à

可以采用默认的“自动识别卡” 或 下拉列表选择对应的CH38x PCIe板卡类型à"安装驱动"

安装过程中出现这个提示不用理睬，系统反应和驱动安装进程不同步而已，

驱动正在正常安装。

驱动安装成功

目录

Copyright (c) 2021 wch.cn All Rights Reserved


2、驱动卸载

2、驱动卸载

运行 PUMPSETUP.exe à 可以采用默认的“自动识别卡” 或 下拉列表选择对应要卸载的的CH38x板卡类型à"卸载驱动"

目录

Copyright (c) 2021 wch.cn All Rights Reserved


3、查看设备ID

3、查看设备ID

运行 PUMPSETUP.exe à点击“遇到问题请点击”按钮à点击“查看设备列表” 选择 “所有PCI设备” 找到相应硬件后，查看硬件ID即可。

该功能可用于驱动安装异常时检查硬件是否正常、系统是否找到硬件等。

目录
Copyright (c) 2021 wch.cn All Rights Reserved


4、修改串/并口号

4、修改串/并口号

运行 PUMPSETUP.exe à点击“遇到问题请点击”按钮à点击“修改串并口号” 按钮，检测到CH38x 的串并口后，指定需要改动的COM口和LPT口号。

修改并口LPT 口号：

修改串口COM 口号：（支持多个串口同时修改）

如果串口号已经被占用或未释放，会有如下显示，可根据串口实际使用情况选择是否继续更改。

修改成功显示，有些机型需要重启才显示设置成功。

目录
Copyright (c) 2021 wch.cn All Rights Reserved


联系我们

联系我们

技术支持邮箱：tech@wch.cn或者tech@winchiphead.com

目录

Copyright (c) 2021 wch.cn All Rights Reserved